(us-east-1 region) Latency of Voice Transcriptions and Summarization

Incident Report for Cresta

Postmortem

The post-mortem for this incident is available on our Help Center under Service Notifications. You can access it directly via this link: https://support.cresta.com/hc/en-us/articles/42539235341339-Oct-20-2025

Posted Oct 24, 2025 - 08:58 PDT

Resolved

Impact from the AWS us-east-1 incident has cleared. Transcription and summarization performance has returned to normal and new workloads are processing as expected. We will continue to monitor. If you still see latency or missing data after recovery, please contact Support with 2–3 examples and local timestamps.
Posted Oct 20, 2025 - 13:59 PDT

Update

AWS is actively mitigating the us-east-1 incident, and upstream services are stabilizing. Cresta services in this region may still experience intermittent delays or errors in voice transcription and summarization. No action is needed on your side; most requests succeed on retry. We are monitoring closely and post updates as recovery progresses. Track AWS’s updates here:

https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 12:41 PDT

Update

We’re seeing some improvement as AWS continues mitigation efforts, though services in us-east-1 remain partially affected. Transcription and summarization performance has improved but latency and occasional failures may still occur. We’re continuing to monitor recovery and will share further updates as AWS restores full functionality. Track AWS progress here:

https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 11:14 PDT

Update

We are still seeing impact from the AWS incident. AWS is throttling new EC2 launches, which is preventing our speech-to-text engine from scaling. Transcription latency remains elevated and there may be intermittent failures. Other regions are healthy.

Mitigations in progress. As upstream services recover, backlogs will drain and performance should normalize. We will continue to monitor and post updates as recovery progresses. Track AWS updates here:
https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 10:14 PDT

Update

AWS reports the network connectivity issue stems from an internal subsystem that monitors the health of Network Load Balancers. To aid recovery, they’re throttling new EC2 instance launches while they roll out mitigations. We continue to see gradual improvement and are working to reduce transcription slowdowns as upstream services stabilize. Track AWS’s updates here:
https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 09:03 PDT

Monitoring

We're currently impacted by the ongoing AWS us-east-1 outage. This is affecting several core systems across the internet including our service. AWS Engineers are actively restoring DynamoDB and related DNS components. Our team is monitoring their updates and will restore full functionality as soon as upstream service stabilize. We're working to improve the current state of our slowdowns of transcriptions due to this. You can read more on this outage here:

https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 07:44 PDT
This incident affected: Agent Assist - Voice (Live Transcript, Knowledge-base Search, Guided Workflow, Call Flow, Cresta Builder - Keyword Triggers, Knowledge Assist, Auto Summarization).